Jul 13

Hace pocas horas anunciaban en PHP.net que sólo se seguirán lanzando releases de PHP4 hasta finales de este año.

Justo hoy PHP5 cumple tres años de vida, durante este tiempo se ha convertido en una versión sobradamente preparada para entornos de producción. Aunque desgraciadamente todavía se sigue usando PHP4 en muchos proyectos y hostings con lo que se limita gravemente el correcto crecimiento del lenguaje PHP.

Esta noticia de fin de continuidad del PHP4 el 31-12-2007 es el complemento perfecto a lo que nos comentaba Dani, entre otros, acerca del nacimiento de GoPHP5, una campaña que propone el próximo 5 de Febrero como fecha límite para que el máximo número de aplicaciones PHP marquen la versión 5.2.0 como requisito mínimo.

Según Nexen.net actualmente sólo un 20% de todas las instalaciones de PHP son de la versión 5, entre GoPHP5 y esta noticia mucho me temo que en menos de 6 meses esta situación por fin cambiará.

Vía PHP.net

Tagged with:
Jul 12

Hace un par de días anunciaron en el blog de las PEAR la disponibilidad de un nuevo estándar donde se describen los cambios necesarios en las reglas de las PEAR para hacer frente, entre otros requisitos, al nuevo instalador Pyrus y a la nueva característica unzip-and-go de las PEAR2. Desde el post se llama a la participación en la página de discusión de la wiki.

Se tratan temas como la estructura de directorios, nombres de archivos y clases, dependencias entre clases, como trabajar con el repositorio, etc.

En la misma wiki puedes ver una lista completa de los problemas q este nuevo estándar quiere solventar. Es realmente interesante la nueva característica unzip-and-go de las PEAR2, permite a quien quiera usar sólo una o dos clases PEAR se las pueda descargar y utilizar directamente sin necesidad de usar el instalador.

Vía PEAR Blog

Tagged with:
Jul 11

Aunque unos días tarde (demasiados) me solidarizo con Julio Alonso publicando este post con el título “SGAE = Ladrones” tal como propone Tabernil.

Para el q no sepa d q va esta historia porque ha estado enfermo, vive en una cueva o un motivo similar, un resumen rápido:

El 23 de Abril de 2004 Julio Alonso publicaba en su blog un post acerca del Google Bombing lanzado contra la SGAE con la palabra “ladrones”. Pues tres años después Julio Alonso informa de que ha sido demandado por la SGAE exigiéndole la retirada del post y sus comentarios, una rectificación pública y el pago de 9000 euros… ver para creer.

Vía Menéame

Tagged with:
preload preload preload